Tech Authority file downloads

Benjamin Diagnostician Tennessee Posted   Latest  
Resolved
Programming
2005 Dodge Ram 2500 Laramie 5.7L (D) 4-spd (48RE)

Has anyone had issues today (or recently) using Tech Authority to download programming files for older pre wiTECH vehicles. The token verification is a joke!! I have been logged in twice now, for some reason I can’t download the programming file, and then I need a new “Verification Token”. I have tried to Download the file with Java Version 8 update 121, and uninstalled that and tried with version 8 update 45. The file will not download and I am constantly being asked for a new Verification Token. I have always had issues with these older Chrysler vehicles, but never like this!!

0
Jamey Owner/Technician
California
Jamey Resolution
 

Are you going through Tech Tools?

+2
Resolution Ð Awarded
Resolution
John Owner/Technician
Pennsylvania
John Default
 

I went through something similar Friday 12-13-19 I was doing a 2009 Grand Caravan 3.8 Six speed and had this happen three or four times before allowing me to download the files.

0
Default Ð Awarded
Benjamin Diagnostician
Tennessee
Benjamin Default
 

As always you are a genius Jamey Thornton. I had Tech tools on my desktop and completely forgot about using that. The file downloaded perfectly. I haven’t had to do one of these older Chrysler’s in a while and forgot all about using Tech tools. Thank you!!

0
Default Ð Awarded
Jamey Owner/Technician
California
Jamey Default
 

I make the same mistake every time I flash a Legacy vehicle.

0
Default Ð Awarded
Benjamin Diagnostician
Tennessee
Benjamin Default
 

Quick question. I am away from the vehicle now, but if I am using a controller technologies DRB3 emulator it should still find the file correct? I also have a Cardaq plus 2 I use with the legacy software. I noticed when using the tech tools it saved the file to a different folder then I am used to seeing. I went ahead and copied the file to my desktop so I can move it as needed.

0
Default Ð Awarded
Jamey Owner/Technician
California
Jamey Default
 

It should find it. Just make sure you delete the old files (if any are there) before you download it.

+1
Default Ð Awarded
John Owner/Technician
Pennsylvania
John Default
 

Hi, i wasnt using tech tools, i dl it from techauthority site and installed it, now it wont let the j2534 server start. I ipdated the cardaqm and no change.

0
Default Ð Awarded
Jamey Owner/Technician
California
Jamey Default
 

If you have current Java installed, it will not work. You will need to un-install Jave and download an older version. Version 8, 121 is what I am using.

0
Default Ð Awarded
John Owner/Technician
Pennsylvania
John Default
   

i unistalled latest java and dl v 8-121 i dont see the j2534 server starting no green dot in the tray. and when i enter a vin nothing happens at all in tech tools. Its not as much fun being the IT guy as it is just flashing a pcm Is it? I appreciate you taking time to help. Also in tech tools it says device not connected in device set up

0
Default Ð Awarded
Jamey Owner/Technician
California
Jamey Default
 

I wish I could walk you through this, however when I do a legacy vehicle, it is trial and error, I can never remember the exact steps and have to play around until I get it figured out. I know that once you open Tech Tools, it should take you to the Tech Authority log in box. Then you can download the file. Your device then finds it in the folder. Sorry I can't be more help. If I can I will…

0
Default Ð Awarded
John Owner/Technician
Pennsylvania
John Default
 

I understand. Thanks fir trying.

0
Default Ð Awarded
John Owner/Technician
Pennsylvania
John Default
 

Yes, i dont do a lot of programing but today i was trying to do a 08 Jeep liberty and its as if i wrote this post. Im having trouble with jaca starting. The authentication seems like a way to waste your time and very annoying too. i gave up for the day when i started getting the never ending spinny thing when i tried logging into Techauthority. I use cardac m and ie 11 and have dl the java they…

0
Default Ð Awarded
Benjamin Diagnostician
Tennessee
Benjamin Update
   

One thing is for sure... it is obvious to me, FCA is putting zero dollars into making the older stuff user friendly. I noticed the big “as of 12/12/19“ message on their website today. I am mobile and constantly am changing internet connections. I don’t have the time to wait an hour for a Verification Token. If I leave and come back I have to start the whole process over again. The secondary…

+1
Update Ð Awarded
Agree
Geoff Diagnostician
Hawaii
Geoff Default
 

"One thing is for sure... it is obvious to me, FCA is putting zero dollars into making the older stuff user friendly" Well, yeah, we're lucky we can get the stuff at all. 15 year old tech is nobody's money-maker. Kinda surprised there aren't pirate discs with all the calibration files out there, like with GM and TIS2000. Or a Chinese DRB-III+ (plus meaning all the old calibrations come on an HDD)

+1
Default Ð Awarded
Kabel Technician
Hawaii
Kabel Default
 

Are you holding out on me Geoff? Where are my copies? Lol I just hope they go to one subscription cost so that you don’t have to have pay for Tech Authority and WiTech to program the 2009 and later stuff. Last time I had to download the legacy stuff it took 7 tries before I got it to work.

0
Default Ð Awarded
Jamey Owner/Technician
California
Jamey Default
 

I get a few legacy vehicles in here because the local dealership doesn’t want to work on them. I doubt if they even have a working DRB III. Or at least anyone who knows where it is and how to use it. I can’t say I blame them. I’m sure they have plenty of Witech 2.0 vehicles lined up needed repair. 😎

0
Default Ð Awarded
Paul Owner/Technician
California
Paul Default
 

2009 Dodge 2500 6.7 using J2534 latest download software legacy I was just about to post this exact thing. Windows 8 tech authority I get to software selected download and get the always allow message and nothing else. Tried 4 different PC s and no go. Tech authority help/no help line goes right to a busy tone and they dont answer email.

0
Default Ð Awarded
Benjamin Diagnostician
Tennessee
Benjamin Update
 

I am finally getting somewhere!! Techtools did it’s job. I forgot to select DRB3 emulator the first time so it could not find the file. I had to clear out the temp folder Then attempted the download again using Tech Tools and selecting DRB emulator. Thanks everyone!

0
Update Ð Awarded