2014 Dodge Durango Information Center

John Owner/Technician Prospect Park, Pennsylvania Posted   Latest  
Question
Infotainment
2014 Dodge Durango Citadel 3.6L (G ERB) 8-spd (8HP70)
Infotainment System
Grey Screen Radio Or Other Functions Unavailable

We downloaded files from unconnect , system unable to read. Bcm responding, no communication to radio through Zeus or Verud Checked fuses In Integrated power module all good. Looked for rubbed through wires in driver footwell none found. Multiple U codes like bus ring interrupted just not sure we’re to go. Can communicate with amp. Thinking either radio is shorted or wiring to radio shorted. Wiring diagram shows 2 inline fuses to radio. Any pointing in correct direction would be great help.

0
Dean Owner
Albany, New York
Dean Default
 

John, What was the original customer complaint? Did you load files on the USB thumb drive from the uconnect website? And tried to update the radio by inserting the USB into the USB port in the vehicle, correct?

0 Default Ð Bounty Awarded
John Owner/Technician
Prospect Park, Pennsylvania
John Default
 

Yes we did download we thought that was the issue, not sure if customer tried to do update and didn’t follow instructions or radio failed or broken wire. Original complaint screen was grey. We did download ourselves I’ve done numerous times this one just has me baffled’

0 Default Ð Bounty Awarded
Caleb Diagnostician
Mishawaka, Indiana
Caleb Default
   

Agree with Dean. What was the customer complaint? Also these systems are fairly simple. Do you have U0184 loss comm with radio? Is the radio the only module offline? Did you attempt the USB update to correct a no comm radio or did the no comm radio occur during the USB updates? Either way if its no comm this should be simple. Just pull the radio check power grd an CAN lines to it connected and…

0 Default Ð Bounty Awarded
John Owner/Technician
Prospect Park, Pennsylvania
John Default
 

That was my thought it was a bad radio but I will pull tomorrow and check . It seemed like a software issue originally but I’m more inclined to believe it’s hardware. Back to basics. Go through all data lines to see if we have power and ground then go from there.

0 Default Ð Bounty Awarded
Raul Owner/Technician
Stuart, Florida
Raul Default
 

I've had few issues with that system, a/c would stop working. After a reset was done everything worked for a few weeks. At times you could only control radio from steering wheel. I would check for any recalls for radio. My issue ended up being radio infotainment system.

0 Default Ð Bounty Awarded
John Owner/Technician
Prospect Park, Pennsylvania
John Default
 

Feeling same way, can’t turn off screen, tried getting in from scanner and witech no luck. Radio seems unresponsive.

0 Default Ð Bounty Awarded
Raul Owner/Technician
Stuart, Florida
Raul Default
 

Disconnect battery do the 10 sec cable together reset. My bet is itll reset

0 Default Ð Bounty Awarded
John Owner/Technician
Prospect Park, Pennsylvania
John Update
 

My U code was U0147:00 Lost communication with telematucs gateway,. Had low voltage codes originally due to screen staying on changed battery, checked charging system cleared codes all was well now just cant get communication to infotainment. Do believe i may have hardware or hard wire issue not software.

0 Update Ð Bounty Awarded
Raul Owner/Technician
Stuart, Florida
Raul Default
 

I've seen so many of these go bad. I believe it's in the radio infotainment unit

0 Default Ð Bounty Awarded