Bmw F10 no communication to left side headlight module

Prakash Mechanic New York Posted   Latest   Edited  
Unsolved
Programming
2014 BMW 535i 3.0L (N55B30A) 8-spd (GA8HP45Z)

The car came from another shop where the headlight module were replaced with oem part due to the fact water was getting inside of the light. The other shop sealed the headlight and was able to get the right side one working. The actual low beam works and turn signal, just the drl/park light/halo rings don’t work. In the foot module I got codes 800fc8 and E59522. I already over lay new wires from foot module to headlight module and from gateway to headlight. weird thing is when I disconnect the right module I still get communication to the right module from the left headlight, so it is as if both module think it’s for the right side. also if I saw the module from the right side to left it will work on the left headlight but not on the right. I saw this bulletin static​.​nhtsa​.​gov/odi/tsbs/2014…

but I do not know what module I have to update. I already tried the foot module to update. I used Autoland , I also have autel too. Any help would be appreciate.

0
Justin Mechanic
Tennessee
Justin
 

[REMOVED]

0
Ð Awarded
Prakash Mechanic
New York
Prakash
 

Yea that is correct and with either side module connected, they will read as the right side module

0
Ð Awarded
Boyd Technical Support Specialist
Georgia
Boyd
 

Did you perform the teach in function under service function setup after programming?

0
Ð Awarded
Prakash Mechanic
New York
Prakash
 

Yes I did for the right side

0
Ð Awarded
Jorge Owner
Nevada
Jorge
 

Check the module in the headlight, it’s probably not sitting in place all the way in.

0
Ð Awarded
Francisco Diagnostician
Virginia
Francisco
 

When the other shop replace the headlight did they replace the module for the halo and DRL? Usually the new headlight comes empty!

0
Ð Awarded
Daniel Technician
California
Daniel
 

I would recommend updating the entire vehicles I level using ista and the factory head only. The other shop may have tried to program it with a after market tool and locked it up. I've seen it happen multiple times. I've recovered many locked up module using the factory head and updating/ coding the entire vehicle. Be sure to plug the icom into your internet router not your PC for a better…

0
Ð Awarded
Boyd Technical Support Specialist
Georgia
Boyd
 

Make sure the FRM is not in shut down mode on that headlamp circuit. If so run the FRM reset routine with your ISCAN 3 and retry.

+1
Ð Awarded
Helpful