Evap Monitor wont set

Mark Owner/Technician California Posted   Latest  
Unsolved
Drivetrain
2007 Chevrolet Express 1500 5.3L (Z L59) 4-spd (4L60-E)

This is for my personal work van The Evap monitor won’t clear just says incomplete drove the van almost 300 miles stop and go fuel level at 3/4 of a tank, any tips???

-1
Missing Info
Missing Tests
Kevin Manager
New Jersey
Kevin
   

Try running a service bay test with a scan tool. This is a good way to get the monitor to run. Or see where a problem may be.

0
Ð Awarded
Justin Technician
Georgia
Justin
 

Is the engine getting up to temperature?

0
Ð Awarded
Mark Owner/Technician
California
Mark
 

Yes

0
Ð Awarded
Mario Diagnostician
California
Mario
 

Hey Mark, verify the integrity of the fuel tank pressure sensor, make sure it is not stuck high or low without setting codes, also the fuel level sending unit is an important input for this monitor to run

0
Ð Awarded
Richard Technician
New York
Richard
 

I'm pretty sure you need to have between ¾ and ¼ tank of gas for it to run also believe it needs to sit overnight

+1
Ð Awarded
Agree
Obie Technician
Washington
Obie
 

I agree the fuel level needs to be in a certain range. Also scan the ambiant temp in the ECM. Won't play if the temp indicates below 42-44 degrees.

0
Ð Awarded
Eric Owner/Technician
Michigan
Eric
 

Consult SI for the run criteria. Probably something as simple as one of the items isn't being met.

0
Ð Awarded
Glenn Owner/Technician
Texas
Glenn
 

You have run 300 miles in stop and go traffic and still at ¾ of a tank? That sound too good to be true, especially if you are loaded down.

0
Ð Awarded
Mark Owner/Technician
California
Mark
 

after I did transmission and connected back the battery I have put 300 miles , what I ment with the fuel level is that I have been trying to keep it at that level to set monitors

0
Ð Awarded
Glenn Owner/Technician
Texas
Glenn
 

Hi Mark, Don't keep topping it off. The monitor should complete when tank is between ¾ and ¼. The fuel level is watched by the computer on most modern vehicles.

0
Ð Awarded
Timothy Owner/Technician
Wisconsin
Timothy
 

Evap only runs when the vehicle is cold-started, and it will usually only try once per key cycle. You'd have to drive it quite a while to get it to run while driving. It can happen but not very often, and takes quite a cruise. It will attempt to run it anytime the tank is above 15% and 85%, but most OEMs use around a half tank for most monitors. Use your scanner and check which codes have not…

0
Ð Awarded