Confusing service info

Hairul Mechanic Malaysia Posted   Latest   Edited  

Hi everyone. Recently one of my buddy hit me up for assistance. I'm not much of a help, and he's decided to call an ABS module after testing everything.

So I came here to discuss about my findings (or the lack of) in FACTORY service information during my attempt at helping him. The car is an automatic Perodua Axia with ABS.

The car set a P0500. I look through the content of diagnosis codes for automatic transmission models and didn't find the code. Then, I look through a similar table but for manual transmission variant and there it is. I've attached what I've found about the code from the service info. Please let me know if my photos are of low quality

My questions are:

1. How is it possible for an A/T variant to set a code that's listed as only available for M/T models?

2. Where can I start the diagnosis? I don't even understand what the output conditions are.

I hope to get some help here, I'm really struggling with the service infos. I've already contacted different technical support and instructor from factory.

0
Glen Owner/Technician
Illinois
Glen Default
   

Any Can bus, Meter or ABS codes?

0
Default Ð Awarded
Hairul Mechanic
Malaysia
Hairul Default
 

No. But the car isn't really my concern. My inability to understand the information is. But anyway, I will attach the scan data.

0
Default Ð Awarded
Paul Mechanic
Illinois
Paul Default
 

You stated he called an abs module. Does that mean he replaced it? Used or new? If used, is it possible it came out of a vehicle with a manual transmission? Not familiar with the vehicle your working on and pictures are a bit difficult to study for content, although schematic seems easy enough to follow except no vss listed, so I assume the wheel speed sensor(s) info gets bussed into ECM from…

0
Default Ð Awarded
Hairul Mechanic
Malaysia
Hairul Default
 

"You stated he called an abs module. Does that mean he replaced it? Used or new? If used, is it possible it came out of a vehicle with a manual transmission?" During my last contact with him, he didnt replace it yet. "Not familiar with the vehicle your working on and pictures are a bit difficult to study for content, although schematic seems easy enough to follow except no vss listed, so I…

0
Default Ð Awarded
Robert Diagnostician
California
Robert Default
 

The code is for no speed signal when the engine rpm is above 1160 RPM and in fuel cut off mode(decell). The wiring diagram does not show which computer receives the speed sensor input. Then the signal is shared with the other modules. The test wants you to see if the speedometer works correctly. It says if it works correctly then the problem is intermittent. I would clear the code and see if it…

0
Default Ð Awarded
Hairul Mechanic
Malaysia
Hairul Default
 

"The code is for no speed signal when the engine rpm is above 1160 RPM and in fuel cut off mode(decell)." So that is the output condition? I didn't realize that fuel cuts off means decel. So does that mean the computer will only monitor for P0500 when rpm between …, coolant temp at least -10 degrees and the engine is in decel? And it'll set the code if it sees the speed below 5km/h…

0
Default Ð Awarded
Glen Owner/Technician
Illinois
Glen Default
 

Hairul I would follow the diagnostics test for the C1237 or post the testing steps so we can help based on that information.

0
Default Ð Awarded
Joel Diagnostician
California
Joel Default
 

I would start diagnosys the c1237, check in the abs module the 4 vehicle speen sensor you already have a dtc for it. This vehicle seems like the vehicle speed is made from abs unit, input the 4 wheel speed sensor .

0
Default Ð Awarded