Volvo c70 2007 D5 limp mode

Aly Diagnostician Congo Posted   Latest  
Resolved
Electrical
2007 Volvo C70 T5 2.5L (B5254T3) 6-spd (M66W)
Check Engine On
Limp Mode

Hi,

i have this volvo c70 2007 that enters limp mode when 2 faults code come on.

faults code are:

1600:boost pressure sensor,signal out of permissible range.

1000:atmospheric pressure sensor ,faulty signal.

plz look to attachment to the value of sensors and advice.

thanks

thanks

-1
Missing Tests
John Owner
Mississippi
John Default
 

Have u checked for any turbo leaks

0
Default Ð Awarded
Aly Diagnostician
Congo
Aly Default
 

No not yet,but i will do if u think that i have a turbo leak thanks

0
Default Ð Awarded
Phillip Diagnostician
Alaska
Phillip Default
 

What checks have you done? What have you tested?

0
Default Ð Awarded
Aly Diagnostician
Congo
Aly Default
 

Hi, when I see the difference between pressures value of the manifold sensor and atmospheric sensor I think that the manifold sensor maybe faulty,but I need to be sure to do order. thanks

0
Default Ð Awarded
Albin Diagnostician
Washington
Albin Default
 

What were the engine operating conditions when this scan data was taken? I see you have no boost, but the desired boost is very close to actual, which is very close to BARO

0
Default Ð Awarded
Aly Diagnostician
Congo
Aly Default
 

Hi, this scan data is at ignition on and engine idle. But i notice that actual manifold pressure and atmospheric pressure not equal as the ignition is on ,is this normal?! thanks

0
Default Ð Awarded
Albin Diagnostician
Washington
Albin Default
 

The Baro & MAP should be very close at KOEO. Here on this side of the pond, ours would be in either "HG, or in PSI. in calculating your readings, the calculations are 1095 HPA = 32.34 HG or 15.88 PSI, 1029 HPA = 30.39 or 14.39 PSI, 1005 HPA = 29.67HG or 14.57 PSI. This is enough different to make me want to go and investigate and make sure something wasn't askew with the MAP sensor.

0
Default Ð Awarded
Caleb Diagnostician
Indiana
Caleb Default
 

Can you please give us this data with key on engine off?? That will let us help you.

0
Default Ð Awarded
Robert Diagnostician
California
Robert Default
 

Looks like the scanner is saying you are creating boost at idle. Do you have a separate map sensor and boost pressure sensor? Can you take vac/p[ressure readings and see if they match the sensors? If you look at the boost pressure and atmospheric sensor with KOEO they should read the same. If not one or both are faulty. Good Luck

0
Default Ð Awarded
Aly Diagnostician
Congo
Aly Resolution
 

solved ,I replace the boost pressure sensor and car works well(VOLVO C70 AND RANGEROVER SPORT 2011 5.0 HAVE SAME BOOST PRESSURE SENSOR) THANKS FOR YOUR REPLIES

0
Resolution Ð Awarded