Witech Flash Subscription

Todd Mobile Technician Morinville, Alberta Posted   Latest  

I did some diag on a 2017 Ram 6.7 last night, when I hooked up my pod I got the update message.

Today I am on a 2011 Avenger and I get this:

0
Todd Mobile Technician
Morinville, Alberta
Todd Default
 

I also got this while trying to access on TA but built a couple other vehicles and the info showed up OK. Man,am I getting paranoid! But can you blame me?

+1 Default Ð Bounty Awarded
Charles Owner/Technician
Turlock, California
Charles Default
 

Starting last week along with your license and subscription they rape you for you have to pay $35 for each car you program.

+1 Default Ð Bounty Awarded
Todd Mobile Technician
Morinville, Alberta
Todd Default
 

Not last week for me, yesterday on the announced date.

0 Default Ð Bounty Awarded
Daryll Diagnostician
Seymour, Tennessee
Daryll Default
 

Earlier today I had a situation where I could not use the Witech 2.0 J2534, program would constantly drop connection to my pass thru. Called support, was on hold for over 30 min to get sent up to “Level 2” but had to hang up and move on. Was unable to do anything with the program. Not a good day for J2534

0 Default Ð Bounty Awarded
Paul Technician
Upland, California
Paul Default
 

Hi Daryll, I had a similar issue last Thursday with my Pass Thru Pro 3 and a 2012 Fiat 500 Pop. I too had to call Tech support, and found out my PTP3 wasn’t able to communicate with the car. It uses a type of can system that my JBox couldn’t communicate with. Kinda weird, as I’ve used that Jbox on 2016 and 2017 vehicles. So I called Snap On tech support, and they verified what wiTech said. So, I…

0 Default Ð Bounty Awarded
Daryll Diagnostician
Seymour, Tennessee
Daryll Default
 

Sounds like a MEGA CAN car then. In my case, I tried 2 different brand interfaces (Pass thru pro 4 and Bosch M-VCI) with the same result, but my scan tool could to an auto id and full scan with no problem. There’s an issue in the software

0 Default Ð Bounty Awarded
Jon Mobile Technician
Ozark , Missouri
Jon Default
 

I know they just started charging a new programming fee that was supposed to start July 15. Here is the link kb​.​fcawitech​.​com/article/325/ve…

0 Default Ð Bounty Awarded
Todd Mobile Technician
Morinville, Alberta
Todd Default
 

I was kind of replying to a post by John Rogers ( I think) a couple weeks ago. I'm sure most guys have encountered the new "fee" by now.

0 Default Ð Bounty Awarded
Tyler Owner/Technician
Fort St. John, British Columbia
Tyler Default
 

same issue... it's a shame they didn't leave anyone who had already bought the year subscription to techauthority let them fulfill there subscription before charging the extra fees. I wonder if we could get a group together that had current subscription and fight to have a rebate as when I renewed my year subscription it was for flash ability for a year not 6 month then change it to cost extra…

+2 Default Ð Bounty Awarded
Agree
Richard Diagnostician
Patchogue, New York
Richard Default
 

Chrysler is the most expensive for programming out of the big 3 even toyota gives you diagnostic with their subscription.

0 Default Ð Bounty Awarded
James Technician
Newport, Kentucky
James Default
 

Chrysler is getting to be worse then Volvo haha

0 Default Ð Bounty Awarded