Smart ForTwo Electric Issues

Michael Owner/Technician Quebec Posted   Latest  
Resolved
Electrical
2014 Smart Fortwo Electric Drive 1-spd
Hv System Error

Hey Guys i have a 2014 Smart fortwo Electric. came in for an A/C condenser replacement from another shop. i removed the HV service plug as i always do on these vehicles, took apart the front body work replaced the condenser refilled the system installed the service plug all went well.... Starts up (Ready) no problem & drives but i have the HV system malfunction in the cluster and its setting the following codes.

P0A0B:00 - the interlock circuit of the high voltage on-board electrical system is faulty

B2735:00 - The Pyrofuse has a malfunction

B11D1 (in restraint systems) - no description

Seeing as the vehicle will power up & driver i don't know if i have an issues because i'm using an Autel or if i actually have an issues 

Wondering if anyone with a little more experience on these has any ideas...

Thanks 

0
Matt Technician
Massachusetts
Matt Default
 

I have limited experience with these but if there were active faults in the interlock system the vehicle shouldn't go into Ready mode. Maybe the Autel doesn't have ability to clear the code despite the function being present in the tool. Is the pyrofuse in the service disconnect like a Prius? You could try a hard reset (touch the 12 volt battery cables together) and see if the codes are…

0
Default Ð Awarded
Michael Owner/Technician
Quebec
Michael Default
 

That’s what is playing with my head it runs... the fuse is not in the service disconnect...

0
Default Ð Awarded
Steven Mechanic
Washington
Steven Default
 

Along with what Matt suggested, I get the feeling that there are faults stored in a module you might not have access to with that Autel scan tool. For example, on other vehicles when a transmission fault is set, you can have a fault in the TCM and the ECM. If you clear the code in one module, that doesn't mean the code will clear from the other. So, if a fault is set in a module you can't…

0
Default Ð Awarded
Michael Owner/Technician
Quebec
Michael Default
 

That’s what I’m hoping a buddy of mine has the factory tool so I’m going to see if he can clear them for me.... I mean everything I’ve learned about electric and hybrids I don’t see how it would run if there was actually an interlock issue

0
Default Ð Awarded
Matt Technician
Massachusetts
Matt Default
 

Any update?

0
Default Ð Awarded
Michael Owner/Technician
Quebec
Michael Default
 

Yes actually I forgot to update... turns out it was my fault... first smart I’ve done and didn’t know that I had to use the scan tool to unlock the disconnect switch first before removing... luckily for me I have a buddy at a local dealer and he did a software update the computer for me... cause even they couldn't just erase codes.

0
Default Ð Awarded
Matt Technician
Massachusetts
Matt Default
 

Good to know. Thanks

0
Default Ð Awarded
Michael Owner/Technician
Quebec
Michael Resolution
 

Yes actually I forgot to update... turns out it was my fault... first smart I’ve done and didn’t know that I had to use the scan tool to unlock the disconnect switch first before removing... luckily for me I have a buddy at a local dealer and he did a software update the computer for me... cause even they couldn't just erase codes.

0
Resolution Ð Awarded