2013 ML350 KEYLESSGO AKL INOPERATIVE

Justin Technician Alberta Posted   Latest   Edited  
Resolved
Programming
2013 Mercedes-Benz ML350 4Matic 3.5L (276.955 Gas) 7-spd (722.9)
Keylessgo Inoperative
No Key Detected

2013 ML350 ALL KEYS LOST KEYLESSGO PROBLEM

Trying to program a key with IM600, using Xhorse FSB3 Smart Key 433.

IMMO>AUTOMATIC>READ VIN>HOT FUNCTION>ALL KEYS LOST GUIDED>ON VEHICLE

Reads EIS info, reads blank key in programmer, calculates password with IR APB102, generates key file, writes to new key with programmer.

The key works, and the remote buttons work. The keylessgo does not work. No key detected. Vehicle has the removable push button on dash. No faults in keylessgo system, key detection test function shows no key. Anyone know what's going on here?

0
Justin Technician
Alberta
Justin Resolution
 

SOLVED: I assumed that because the remote functions were working that the frequency was correct. Turns out the frequency needed to be changed from 433 to 315 for KeylessGo to work.

+9
Resolution Ð Awarded
Helpful
Agree
Genaro Owner/Technician
Florida
Genaro
 

thumbs up brother

0
Ð Awarded
Timothy Owner/Technician
Wisconsin
Timothy
 

That's interesting. The TPMS sensors in some Euro built GMs use those same frequencies for their TPMS sensors…

0
Ð Awarded
Matthew Diagnostician
Kentucky
Matthew
 

Ya proximity keys generally without remote start output anywhere from 315 to 433 mhz ( just like rpm’s) however remote start keys are 900 mhz or there about. had similar issue recently with customer supplied keys. bad thing is keys will program just not work Recognized by system during the ignition status change. I also now will gene upfront inform customer if keys do not program them further…

0
Ð Awarded