Cluster death? odometer hiding?

Roberto Educator Fremont, California Posted   Latest   Edited  
Question
Driveability
2007 Mercedes-Benz E550 4Matic 5.5L (273.962) 5-spd (722.6)—WDBUF72X17B029927
Odometer Don't Show

Hey euro guys, this cluster had some issues, somebody replace the steering angle sensor and the ABS/traction control module, both items are working normal now, but, the odometer is gone, as you can see is only lines on the screen, I was trying with the help from autologic guys to initiate, do some adaptation on the modules to bring back mileage on the odometer but nothing, according with the tech, he told me that the mileage on the cluster and the ignition switch are more than 500 miles different, and he is correct, I have 198809 km on the cluster and 198272 on the ignition switch, how that happened? I don't know but there is a code on the cluster regarding some unauthorized driver or something like that, car drives just fine, the miles on cluster are going up as you drive, just can't see the odometer but speedometer is normal, the steering angle adaptation is also normal, my question is, is there any way to adjust the mileage on this cluster and get it closer to the mileage on the ignition switch? and do you guys think this is the reason why the odometer is gone? before the repair was done on vehicle the odometer was fine, it was replace along with the ABS/traction control module because the traction light and some other lights were on on the cluster, all the fail lights are gone on cluster but odometer went gone, what you guys think? thanks in advance.

0
Luis Technician
Lake Forest, California
Luis Default
 

Almost every time I see ______ no miles most likely a communication issue. Time to pull wiring diagram and make sure all modules are shaking hands, coded properly

0 Default Ð Bounty Awarded
Manuel Diagnostician
Newark, New Jersey
Manuel Default
 

Pull cluster and open it make sure there isn’t can bus filter on it. Also make sure Id same in eis and cluster or always make ————

0 Default Ð Bounty Awarded
Dien Owner/Technician
Tulsa, Oklahoma
Dien Default
   

Maybe conflicting mileage data in the modules. Some modules cannot be re-flash. need to hard wire and read/write to the chip or board of the module.

+1 Default Ð Bounty Awarded
Freddie Owner/Technician
Houma, Louisiana
Freddie Default
 

Following, because I had a similar issue a few months ago with 2009 ML350 and the odometer was just dashes after we installed a used cluster. The used cluster had 140,000 according to the Autel scan tool and the original had 120,000. For some reason it would not let me correct mileage with the Autel Maxysis Elite.

0 Default Ð Bounty Awarded
Paul Technical Support Specialist
Lafayette, Colorado
Paul Default
   

Used cluster won't fly on a Mercedes-Benz without heroic measures with an Abrites. New one will auto VIN lock and show correct mileage after twenty key cycles. EZ YOU DON’T NEED ANYTHING EXCEPT A NEW CLUSTER!

0 Default Ð Bounty Awarded
Victor Technician
Cudahy, California
Victor Default
   

Hola Sr Roberto Ibarra. How are you? so, you invoqued Euro techs....wright? this is the fact of the matter according to me about this: there is discrepancy in this Job... that discrepancy could have been created in this order: 1- You are not telling us everything 2- Cluster doesn't belong to the car 3- Autologic. let's talk about the 2nd option: 99 % of the times this issue is on…

-1 Default Ð Bounty Awarded
Tim Mobile Technician
Burien, Washington
Tim Default
 

We use a tool called Abrites on these, it allows you to rewrite the data in the modules... Has the cluster been replaced?? or has the mileage been changed and maybe a can blocker been put either in the cluster or the EIS? We run into this a lot with cars coming down from Canada.. They have someone try and change the mileage in the cluster, and they put a can blocker in the module.. If the…

+1 Default Ð Bounty Awarded
Johnny Owner/Technician
Kissimmee, Florida
Johnny Default
 

hi friend you need a new cluster thats the only way to mach the milles and it have to be Scn coding or you have to clone the micro ship on the cluster board I went thru that I end up with a new cluster

0 Default Ð Bounty Awarded
Roberto Educator
Fremont, California
Roberto Default
 

Hi Victor and thanks for the reply, but this cluster does belongs to the car, IO can see a mismatch of 537 Km on the cluster and the ignition switch why? I don't really know, a "guy" who works on Mercedes replace the steering angle sensor and suddenly the cluster has only dots, I'll ask more questions to my friend the owner of the car, I know this guy and he is no lying, about the other guy who…

0 Default Ð Bounty Awarded
Dien Owner/Technician
Tulsa, Oklahoma
Dien Default
 

Hi Roberto, Look into the data stored in the old ABS module. Sometimes the odometer can be stored in multiple modules. Can you plug the old abs module back into the vehicle? See if you can plug only the module and not switch the hydraulics to see if the odometer problem goes away. Dien

+1 Default Ð Bounty Awarded
Roberto Educator
Fremont, California
Roberto Default
 

Thanks Dien for the reply, but unfortunately the old ABS module was an exchange according with the owner, they the rebuilt unit from Mercedes Benz, I saw the receipt myself and it was a remanufactured unit. I'll ask the guys to see if they still have the old unit, thanks

0 Default Ð Bounty Awarded