Right/front thumping noise on 2009 Santa Fe

John Owner/Technician British Columbia Posted   Latest   Edited  
Resolved
Drivetrain
2009 Hyundai Santa Fe GL 3.3L (E) 4-spd
P0750 — Shift Solenoid "A"

We have this truck in for service and a thumping noise from right front. Drove it on 4 post and figured it was right front wheel bearing. Took it off the hoist and drove out the shop. Check engine light came on code P0750. Transmission solenoid code. Cleared code and road tested went into 3rd gear and limp in. Check engine light on. Cleared code and light came on right away. Spoke to customer and they haven’t had a problem with light on or shifting problems. Check the solenoid for power and resistance both ok. Activated solenoid from the pcm by grounding the yellow wire. Solenoid clicks ok. Tried to activate solenoid in function test on snap on versus and Autel. Both can’t activate it. Thinking PCM. but tough call as no issues before driving on 4 post hoist. Anyone experienced this before. Hope you can help. Thanks in advance. John. 

0
Scott Owner/Technician
Iowa
Scott Default
 

Look and see the count or when it happen

0
Default Ð Awarded
John Owner/Technician
British Columbia
John Default
 

What count are you referring to? The check engine light comes on as soon as you put it into reverse or forward. Thanks.

0
Default Ð Awarded
Scott Owner/Technician
Iowa
Scott Default
 

Look at code count on scan tool when it first happen

0
Default Ð Awarded
Laird Owner/Technician
Nova Scotia
Laird Default
 

Try a battery disconnect and hold the cables together to clear everything out. Something to try before going in too deep

0
Default Ð Awarded
Richard Technician
New York
Richard Resolution
 

I know there is a TSB about the wire harness inside the transmission causing codes. It is possible that it is bad. I checked the wire diagram. It appears there MAY be 2 yellow wires going to the solenoids. 1 for the Low/Reverse solenoid and 1 for 2nd gear solenoid. If you want to be sure you could clear the codes and drive the vehicle with some of the solenoid wires in a current clamp. Or use…

+1
Resolution Ð Awarded
Resolution
Ken Owner/Technician
Arizona
Ken Default
 

If the code comes on as soon as you turn the key on...... What is amperage and voltage occurring at the pcm from the shift solenoid when you turn the key on....key on only the pcm is seeing something it does not like...external or internal?

0
Default Ð Awarded
John Owner/Technician
British Columbia
John Update
 

Thanks guys for all info. I rechecked the LR solenoid this morning as there is 2 yellow wires which I did not see yesterdayThanks Richard for that. The yellow I was checking was for the 2nd solenoid which works perfectly. I checked the correct yellow and it is open circuit through the solenoid or wiring. I have now to pull the pan and valve body and see if it’s a harness or solenoid fault…

0
Update Ð Awarded
John Owner/Technician
British Columbia
John Default
 

Ok guys what I ended up doing was taking the valve body cover off and inspected the solenoids and wiring, everything looked ok. I activated all the solenoids using my Autel scanner. All of them worked. In ohmed all the solenoids and they were all 3.2. I put a new solenoid in the LR and reran the activation all them worked. i reassembled it and everything worked fine.. I assume that the solenoid…

0
Default Ð Awarded