Ram 2500 5.7LT 4x4 not engaging

Maria Engineer Carmen, Mexico Posted   Latest  
Question
Drivetrain
Programming
2011 Ram 2500 Laramie 5.7L (HEMI) 5-spd

Hi everyone, we are working on a 2011 RAM 2500 5.7LT HEMI. Clients complaint that the 4WD is Not engaging at all. If you turn the 4wd knob nothing happens. No codes related to the 4wd system. only u0127 which is no communication with tpms module. NO other codes on tipm or CCN. Already checked lines from knob to cluster, from drivetrain control Module to shift motor and everything seems to be working Fine. Months ago the client replaced the PCM. Do you think they missed a calibration when pcm was replaced? Or any other idea of what may be causing the problem? Thanks!

0
Albin Diagnostician
Leavenworth, Washington
Albin Default
 

What does your scan tool show you in data stream about the transfer case? Have you done any testing to see if there is proper power & ground to the transfer case motor & controller? There are a lot of things I would be looking at before I would look at the software.

0 Default Ð Bounty Awarded
Maria Engineer
Carmen, Mexico
Maria Default
 

Yes, we test ground and power and even test the motor itself. Works perfectly. Km thinking at the software because we dont know if tpms (no comm with the module) is affecting the 4wd performance. Ive read that wheel parameters (abs sensors, tiré size,etc) are important for the 4wd performance but i have no idea if tpms can affect like that too.

0 Default Ð Bounty Awarded
Ricardo Diagnostician
Plymouth, Michigan
Ricardo Default
 

If you don't know the full story of repairs first try restoring vehicle configuration, maybe someone replaced tipm with one from 2wd vehicle

0 Default Ð Bounty Awarded
Maria Engineer
Carmen, Mexico
Maria Default
 

According to client's information everything still from factory BUT the PCM. The tipm has a modification but is an outside fuel pump relay . And thats it.

0 Default Ð Bounty Awarded
Chad Mechanic
Chandler, Arizona
Chad Default
 

I actually saw this last year and decided to check my powers and grounds. I pulled the fuse for the transfer case to install a current loop and then it started working again. I see the truck every summer and she has not had the problem since I pulled the fuse and reinstalled it.

0 Default Ð Bounty Awarded
Maria Engineer
Carmen, Mexico
Maria Default
 

Ill check again for power and grounds. Maybe im missing something obvious.

0 Default Ð Bounty Awarded
Brian Instructor
Parma, Ohio
Brian Default
 

Any abs codes? I have had abs wheel speed dtc's , and even a unplugged front wheel speed sensor cause no 4wd operation on 08 and 09 Ram 1500's.

+1 Default Ð Bounty Awarded
Maria Engineer
Carmen, Mexico
Maria Default
 

No codes at abs Module but i have no Communication with tpms Module. You think that can be the problem?

0 Default Ð Bounty Awarded
Caleb Diagnostician
Mishawaka, Indiana
Caleb Default
 

Can we have a VIN please since this truck is in Mexico? Just to be sure we are on the correct vehicle when looking up Service Information.

0 Default Ð Bounty Awarded
Maria Engineer
Carmen, Mexico
Maria Default
 

Attach VIN

0 Default Ð Bounty Awarded