2012 Isuzu NPR 5.2 Too Much Fuel, Black Smoke, Warmup, Regen

Tom Owner Wisconsin Posted   Latest   Edited  
Updated
Drivetrain
Heavy Duty
2012 Isuzu NPR-HD 5.2L (6 4HK1)
Excessive Black Smoke
Overfueling

This truck blows an excessive amount of black smoke on warmup. When the exhaust brake closes to warmup, idle is around 1,000 RPM. After about 30 seconds the engine starts to load up. I see desired and actual rail pressure start to climb from 5k upto 10-11k (Low side Pressure about 120psi). While this climbs Injector 3 Balance goes Negative and Injector 4 Balance goes positive. Once Injector 3 hits about -3 or -4, Injector 4 hits the same on the positive value (3 or 4). Black Smokes starts to come out the exhaust. As the balance rate gets worse more and more black smoke comes out, you can hear the motor loading up and vibrating. Balance rate will go all the way to -8/8 before i hit the throttle to turn off the brake and drop the idle. We have disconnected the exhaust emissions for testing thinking it was a back pressure issue, but it still does it when the pipe is removed right after the exhaust brake. 

List of parts already changed. All 4 injectors(Flow Rates were programmed), DPF,DOC,SCR, Exhaust Brake, MAF, Fuel Temp Sensor, EGR Temp Sensor 2, Doser Injector. Turbo was Replaced 25,000 Miles ago. I checked the Intake Throttle Valve & EGR Valve, the valves seems to be operating normal when commanded to move. Also I can command the Turbo Vanes and they seem to be responding correctly too. 

Also I should note when I try to do a manual Regen, it will start to warmup the DOC/DPF and i watch as soon as Desired/Actual Rail Pressure reachs 10k the truck stumbles and almost wants to die for a couple seconds and then goes back to trying to warmup when it recovers. It will keep doing this when pressure gets up there.

Truck seems to run good down the road. I took it out for a hour drive (before doing injectors, however everything else listed above was already done by the previous owner) to try and get it to auto regen, It went in regen and didn't notice any drivability issues, but about 15 miles afterwards I got a P0172 condition. 

After doing Injectors, Balance rates are tighter but 3 and 4 still go nuts as described above.

I am at a loss here on what other test to perform on this truck. Any ideas out there?

Cylinder Leak between 3 and 4 plausible?

Truck has 140K miles and the original injection pump

0
Helpful
Robert Owner/Technician
Virginia
Robert Default
 

Exhaust brake rusts up will not release pull cover on unit and watch leaver and see if it moves, some times it will work sometimes not

0
Default Ð Awarded
Edwin Mobile Technician
South Carolina
Edwin Default
   

Tom First thing I would do is start with the basics. I would perform a compression test and compare all four cylinders. I would also check to see if you have the latest cal file installed along with doing a bulletin search. If you have the ATS bullseye leak detector i would check for C02. One of the key points you mentioned is as the engine warms up it starts to run bad at idle. Is this running…

0
Default Ð Awarded
Tom Owner
Wisconsin
Tom Default
 

Compression check is my next check to perform. Previous owner said they performed one but I’m starting to check everything they previous checked. Truck has 140k and on the original Injection Pump.

0
Default Ð Awarded
Matthew Mobile Technician
Illinois
Matthew Default
 

I agree that a compression test is where I would go next... at least it is a glow plug engine :-) If compression is good I would start to question the injection pump since your balance rates are still off. Also, does it look like the cylinder head was taken off when the last owner was shotgunning parts at it? I have seen quite a few of cylinder head issues on these, but most of them were…

0
Default Ð Awarded
Michael Mechanic
Texas
Michael Default
 

No change in #s 1 & 2 balance rate when 3 & 4 are dweedelatin'? Can you do a cutout test while smoking, any change when cut out on 3 & 4? Have not seen this before but thought came to mind as reading... verify proper wire connection on 3 & 4...? Don't even know what would happen if that occurred... but a simple check when vcover is off. What is boost pressure while all this is…

0
Default Ð Awarded
Michael Mechanic
Texas
Michael Default
 

Please post your solution afterwards. Thanks

0
Default Ð Awarded
Scott Mechanic
Arkansas
Scott Default
 

Electronic injectors? Any way the leads could be reversed on 3 and 4?

0
Default Ð Awarded
Michael Mechanic
Texas
Michael Default
 

115k miles seems an awfully short time to be needing a turbo. Was the issue there before the turbo replacement? What was reason for turbo relacement... just failed or did it get replaced to try and correct the overfueling? Check the piping for a shop rag in the air to air on the upstream side.

0
Default Ð Awarded
Tom Owner
Wisconsin
Tom Update
   

Issue seems to be resolved It appears when the new Exhaust Brake was put on, it was adjusted incorrectly and allowed it to close too far. I adjusted it till the point where the balance rates stay good across all 4 cylinders. The brake still slows the truck. I got a manual regen to complete and no black smoke on warmup. Reason I went to this one because the brake was the first replacement on…

+1
Update Ð Awarded
Michael Mechanic
Texas
Michael Default
 

Congrats! Appreciate the follow up.

0
Default Ð Awarded