Pinion Factor 2006 PT Cruiser 2.4L Turbo

Alireza Owner California Posted   Latest  
Resolved
Programming
2006 Chrysler PT Cruiser GT 2.4L 4-spd
P0501 — Vehicle Speed Sensor "A" Circuit Range/Performance
Speedometer Doesn't Work Since The Pinion Factor Is Not Set

Hello,

We are working on a 2006 PT Cruiser GT 2.4L Turbo. Since we have replaced the PCM, DTC P0501 sets which means that we have to set the pinion factor. The problem is I can't find a way to do it trying both DRB Emulator and Wi-Tech, Any help is really appreciated.

0
Kerry Mobile Technician
Ohio
Kerry
 

Having been down this road a couple of times over the years specifically on the PT cruisers in this time frame, the vehicle speed calculation and journey of the data varies between manual transmission and automatic transmission as well as with or without ABS. Sometimes the diagrams are not comprehensive so keep an open mind. The first flag to address would be whether or not the computer that…

0
Ð Awarded
Alireza Owner
California
Alireza
   

Thanks for your quick reply Kerry. The PCM is a reman with software blanked to the factory default. We flashed it to the appropriate software (calibration) using J2534. On 2005 Pt Cruisers we can easily set the Pinion Factor under the TCM menu in DRBIII Emulator but we can't find any option to do the same thing for 2006 PT Cruisers using both DRBIII Emulator and Wi-Tech. And do you have the…

0
Ð Awarded
Robert Technical Support Specialist
New York
Robert
 

Pinion factor is in the TIPM not the PCM, the 05 PT did not have a TIPM and was a DRB only vehicle the 06 is a hybrid with a TIPM which is why some functions need wiTECH others need a DRB

+2
Ð Awarded
Agree
Helpful
Robert Technical Support Specialist
New York
Robert
 

Pinion factor is in the TIPM if memory serves me correctly, been awhile since I've had to work on one personally. But didn't mind them as most others at the dealership's I've worked at would avoid them.

0
Ð Awarded
Robert Mobile Technician
Delaware
Robert
   

For some reason I think I remember having this issue and I had to restore vehicle configuration with witech. Just know that currently snap on Altus, Mitchell, auto auth, and tech authority are in a blackout.

+1
Ð Awarded
Alireza Owner
California
Alireza
 

Hi Robert, Thanks for the heads up. Yes, they are down since last night. Do you know or remember by chance which option on WiTech allows me to reconfigure the Pinion Factor for these 2006 PT Cruisers?

0
Ð Awarded
Robert Mobile Technician
Delaware
Robert
 

I had one of these once and the speedo wouldn't work after a pcm was replaced. It has no way to do the pinion factor. I'm certain I had to do a restore vehicle configuration to get the speedo to work.

0
Ð Awarded
Alireza Owner
California
Alireza
 

How do you do the restore vehicle configuration?

0
Ð Awarded
Robert Technical Support Specialist
New York
Robert
 

Under guided diagnostics restore vehicle build configuration

+1
Ð Awarded
Helpful
Alireza Owner
California
Alireza
 

Thank you, Robert.

0
Ð Awarded
Robert Technical Support Specialist
New York
Robert
 

You are welcome. Just trying to assist a fellow tech when I can. Sadly all FCA systems are down so probably not going to be able to do it today.

0
Ð Awarded
Alireza Owner
California
Alireza
 

Yep, unfortunately nothing works now!

0
Ð Awarded
Justin Technician
California
Justin
 

Use a snap on scanner has worked for me in past

0
Ð Awarded
Alireza Owner
California
Alireza Resolution
 

Thanks everyone for your comments and help. My next step is try the “Restore Vehicle Configuration” option.

0
Resolution Ð Awarded
Benjamin Diagnostician
Tennessee
Benjamin
   

Change the tire size to something different than what is on the vehicle, then change it back to the correct tire size. That should fix your problem. It’s common with PT Cruisers.

+2
Ð Awarded
Agree
Helpful