2001 New Flyer 60 Ft. Articulated Bus Random Misfire

Michael Diagnostician Champaign, Illinois Posted   Latest   Edited  
Case Study
Heavy Duty
Random Misfire And No Codes

Good evening everyone, finally have some time to start sharing what I know and have experienced in the HD space. 

This Bus I worked on took a little time to figure out but was very interesting in the end result of what the fix was. The initial complaint on this Bus was excessive black smoke on acceleration and the occasional random misfire. So the first thing I did was I checked for codes and no codes. From past experience, I have seen Injectors leak which will cause this issue so I decided to do a Cylinder Cutout Test with Cummins Insite factory tool. So to elaborate a little further on how the Cylinder Cutout Test works on this engine, the ECM looks at Engine Position and Engine Speed with the two sensors mounted on the back of Timing Cover. When you command a certain cylinder off it knows when to disable the Injection Control Valve on the Injection Pump. 

The Injection Control Valve is responsible for metering the fuel at the exact moment the distributor lines up with the adjacent slot going to that particular cylinder. This Injection Pump on this Bus is a Distributor type Pump with a Accumulator on top that has 2 Pumping Chambers which are electronically controlled by Solenoids. The Pressure is built inside the Accumulator Housing and then goes to the Injection Control Valve for Metering of the Fuel, which meters it at the proper firing order of the Engine. The firing order is 153624 on this inline configuration. 

Here is an example of showing the no 1 cylinder being cut out and me looking at it on my Pico Scope. I did the Cutout Test and noticed that the rpm drops on all of the cylinders were not even. Sometimes they were ok, sometimes they were not. After discussing this with my Foreman we decided to put 6 new Injectors in because of the nature of the problem. 

After doing this, lunch time came and my curiosity made me hook up my Pico Scope to the Accumulator Pressure sensor which is threaded into the back of the Accumulator Housing on this Pump. I was hoping to see Injectors dropping too much pressure. However in this case, I was not seeing what I hoped to see. On the second pic I noticed that as the Engine Started to run the Accumulator Pressure on Channel C the Green Channel was very unsteady at the beginning of Engine Run and then leveled out and lowered. The lowest point of the Green Trace is when the Engine started to idle smooth again. 

I then zoomed in with the Pico at the high peaks and valleys of the Accumulator Pressure Sensor and noticed that 4 of the Injectors were barely dropping any pressure. Then at the end of capture you see somewhat even pressure drops. To be honest, after looking at the scope capture, I was a little skeptical now with the Injectors being the issue. So we had the Injectors done and ran the Bus. 

The next day the bus came back with the same complaint. At this point, I hooked up Insite again and looked to see if any data looked amiss. Everything looked good. Boost was good, I had 38 to 40 inches of mercury, my air filter checked out ok, and the data pid for injection control valve circuit status said normal. So after this I decided to hook up my Pico Scope to the Injection Control Valve because it is in charge of the proper fuel metering to the cylinders. I start up the Bus and I notice that the Icv Current is intermittently dropping out. Awesome! I now have direction on what to do next. In the next file I am zoomed in to look at ICV Valve Current, Voltage, and Pressure, which is channel B the red trace and the ICV Voltage is the Blue Trace. This pic is showing the Icv Valve is staying on longer than it should be and it does not have a clean cut off. Also the Pressure is erratic too and is choppy showing that the Icv Valve is sticking. After seeing this, it was the end of the day and I told the Night Foreman to double check the power and ground wires to the ICV and if it checked out ok, to replace the ICV Valve and the Transient Suppressor. 

I came in the next day and my Foreman told me the problem was still there. So what did I miss? I decided to recheck everything, pump timing, fuel leaks, electrical connectors at sensors, fuel return line blockage, everything was ok. So after this, my foreman wanted me to do a Relative Compression Test with my scope. The Relative Compression Checked out fine. 

After this test I wanted to see if the low side Gear Pump Pressure mimicked the High side on a crank and start. I checked the low side Gear Pump Pressure with a Fluke PV 350. I show in these two pictures how unsteady the pressure is just like the High Side is. I then went back to checking the Icv Valve. I hooked up to Voltage, Ground, Current, and Pressure. The first picture shows me taking a long screen so I can see trends in the signals. This is why I like the Pico Scope so much is because of this feature. I zoom in on the capture and notice that the Accumulator Pressure has huge up and down dips when the Icv is trying to work. The ICV Current then drifts at 2.5 Amps for awhile and the Accumulator Pressure Drops accounts for this. The Red trace which is ground does not look right to me. At first I thought it should be 3 to 400 millivolts at most. However the Ground Voltage is creeping up in conjunction with the Icv Current. My pressure drops are erratic as well. My feed Voltage is good though. 

The reason why we have Black Smoke on Acceleration is because of this Valve not closing properly and therefore putting more fuel into the cylinders. It was the end of the day and I went home and thought about it over night. What could be causing this weird operation of the ICV Valve? At that moment the light bulb went off in my head! When the night shift replaced the ICV Valve did they replace the Transient Suppressor? If they didn't, this would explain this weird operation! The Transient Suppressor is basically a Capacitor which absorbs the Electromagnetic Field Dump of the ICV Valve so the ICV Valve can close properly. If it isn't working you will see this type of operation. Since there is no where for the Electromagnetic Field to be absorbed quickly the Field rings or resonates till all the energy is gone. 

So I came in the next day and we checked the Suppressor and found that the Night Shift had not replaced it! So I proceeded to put a new one on and noticed that while I took it off it was not plugged in! Bingo! I replaced the Suppressor and it had no more Black Smoke! Problem fixed! My Foreman took it out on a Test Drive and had no more issues. 

Here in the last pic shows what a good ICV Circuit and Pressure Drops should look like. You can also see that on the Ground Side it shows the magnetic field spike and the Suppressor is capping it off around 50 Volts. You then see a hump at the end showing that the ICV Valve is closing. This was a very cool problem in my opinion. The Scan Tool Told me nothing helpful whatsoever. If I did not have a scope I would not have been able to find this issue. My Foreman would have told me to replace the entire Pump which is over 2 thousand dollars. I saved the company I work for quite a bit of money. I was initially right in my Diagnosis, it's just the second shift forgot to replace the Transient Suppressor. Any questions let me know.

+10
Adrean Diagnostician
Bakersfield, California
Adrean
 

Love Your stuff bus jockey great content 

0 Ð Bounty Awarded
Michael Diagnostician
Champaign, Illinois
Michael
 

Thanks Adrean, I finally got some time to post on here. Been busy.

+1 Ð Bounty Awarded
Michael Diagnostician
Champaign, Illinois
Michael
   

Just a fyi everyone, I had Scott help with the edits and I believe that we have the images lined up.

+1 Ð Bounty Awarded
Ben Technical Support Specialist
Eaton Socon, United Kingdom
Ben
   

Amazing work here as always Michael! Another example of where the scan tool couldn't help in this situation but it just proves your product knowledge is second to none. What stands out to me is when you were looking at both sides of the ICV valve, supply and control, and current. What I noticed was when the fault was present there is no 'pintle hump' when the solenoid moves back to it's seated position which is wonderfully clear in the fix! No wonder your busy when you get results like this. Keep up the good work!!

0 Ð Bounty Awarded
Michael Diagnostician
Champaign, Illinois
Michael
 

Thank you Ben.

0 Ð Bounty Awarded
Jim Mobile Technician
Southampton, Pennsylvania
Jim
 

GREAT Write up, Michael

0 Ð Bounty Awarded
Michael Diagnostician
Champaign, Illinois
Michael
 

Thanks Jim. Finally got some time again to share, been very busy at my full time job and my daughter started High School. I have been playing Taxi cab, lol.

0 Ð Bounty Awarded
William Diagnostician
Ashland, Virginia
William
 

Excellent write-up!! These kinds of tests and knowledge is what is keeping many techs from diagnosing instead of replacing parts.

0 Ð Bounty Awarded
Michael Diagnostician
Champaign, Illinois
Michael
 

Yes William so True. A lot of the factory service manuals don't give you enough information. So I have collected a ton of known goods with a Scope and also Scan Data. Sometimes you have to dig deep to figure out these issues. I hope this site keeps growing for the HD side because everyone needs it including me, lol. I will be the first one to admit I don't know it all.

0 Ð Bounty Awarded
Albin Diagnostician
Leavenworth, Washington
Albin
 

Nice diagnostic procedure and a very good write up!! I had to read it over three times to get it all digested, since I'm not familiar with that injection system. The only question I have, "was the transient suppressor actually defective, or was it unplugged all along"?

Somehow while I was reading your dialog, my mind was drifting back to the days of ignition points and defective condensers. :)

0 Ð Bounty Awarded
Michael Diagnostician
Champaign, Illinois
Michael
 

Hi Albin I appreciate the compliment. The Icv was faulty. The Technician who took it off said there were pits in the stator, which is the coil. So I think what happened here since the Suppressor was unplugged and affecting the fuel system, the computer was desperately trying to control the fuel distribution which made the computer leave the Valve on longer which makes more heat and caused the coil to crack and pit. So yes I believe the Suppressor being unplugged caused this whole issue. Are you going to Vision this year Albin?

0 Ð Bounty Awarded
Sean Diagnostician
Regina, Saskatchewan
Sean
 

Great job Mike. Hope your doing well. 

0 Ð Bounty Awarded
Michael Diagnostician
Champaign, Illinois
Michael
 

Thanks Sean I'm doing great. I'm just very busy trying to get more things done with my business and working full time at my main job. And dealing with my 14 year old Daughter in High School now. I have been a taxi cab non stop for the past couple weeks, lol.

0 Ð Bounty Awarded
Sean Diagnostician
Regina, Saskatchewan
Sean
 

Lots on you plate bud but it will all be worth it in the end. Hoping to see you in Kansas ;)

0 Ð Bounty Awarded
Tom Owner/Technician
Santaquin, Utah
Tom
 

wood you have any picture of the old parts.

0 Ð Bounty Awarded
Michael Diagnostician
Champaign, Illinois
Michael
 

Sorry Tom I dont. I didn't get the opportunity to take pictures. The night Tech who replaced it told me the stator was pitted and then I asked the same thing you did. He told me he threw it away. Good to hear from you. How are you?

0 Ð Bounty Awarded
Tom Owner/Technician
Santaquin, Utah
Tom
 

Good, been busy, I have to call you and talk some more if we ever get time.

0 Ð Bounty Awarded