Monitors not Completing: EVAP, Oxygen Sensor, Catalyst

Gardy Owner/Technician Morganville, New Jersey Posted   Latest   Edited  
Question
Emissions
2006 Chevrolet HHR Comfort LT 2.4L 4-spd
Obd Monitors

Vehicle had a chewed up evaporation canister plug, fixed issue vehicle has been driven according to identifix procedures to reset monitors got all monitors to work except catalytic converter, oxygen sensor, and evap system. 

I have driven the vehicle over 150 miles, customer has driven vehicle over 350 miles and still nothing. Customer replaced heated oxygen sensor due to a lazy old one and still monitors have not set. Cruise control is not working and vehicle hit fuel cut off at 4 thousand RPM while accelerating or feels as if it has activate a governor to not let it shift up and past 4k RPM. No codes have been set, if driven softly vehicle rides normal and shift with no problems. 

My main concern is the monitors not been able to set, any help with ideas of where to go from here. 

0
Scott Manager
Claremont, California
Scott
 

Hi Gardy, On the cruise control/rev limiter symptom, I would look to see if the P/N input to the ECM is correct. Not sure if this is preventing certain monitors from running but it's likely.

+1 Ð Bounty Awarded
Gardy Owner/Technician
Morganville, New Jersey
Gardy
 

Thank you for the answer, i will take a look and see what it shows.

0 Ð Bounty Awarded
Joel Diagnostician
Soquel, California
Joel
 

Check with engine stone cold the temperature of the iat and ect should be no mere than 10 degrees in between ech other according to ambient temp, also after you stat up the engine monitor how long it is taking to reach normal temperature 180 f. check on scanner vehicle speed data on pcm , is it in closed loop ?

0 Ð Bounty Awarded
Anthony Technical Support Specialist
Kirkwood, Pennsylvania
Anthony
 

Hi Gardy: Take a look at the blocking criteria for codes associated with the monitors which aren't running. You may also wish to glance at OBD-II Mode $09C to see if this has been an on-going issue. If so, there may be a calibration update addressing the issue. gsi​.​ext​.​gm​.​com/gmspo/mode6/pd…​.​pdf Also, you will need to determine if the…

+1 Ð Bounty Awarded
Darren Mechanic
West Allis, Wisconsin
Darren
 

Possible small exhaust leak biasing downstream 02 sensor. Also check fuel trims.

0 Ð Bounty Awarded
Gardy Owner/Technician
Morganville, New Jersey
Gardy
 

Thanks everyone for all your help, Found transmission not upshifting and cutting out due to a broken wire chew up by an animal to the TCM however did not show any fault codes for it. Fixed ground wires as well due to animals chewing it. All monitors ran properly no issue after that.

+1 Ð Bounty Awarded
Scott Manager
Claremont, California
Scott
 

Hi Gardy, Was this causing a P/N indication all the time?

0 Ð Bounty Awarded