GM SPS Failed

Brian Owner/Technician Amanda, Ohio Posted   Latest  
Discussion
Programming
2008 GMC Acadia 3.6L (LY7) 6-spd (6T75)
Unkown Error During Programming

I was having some problems programming a seat module. There's a couple problems. One being SPS ask for the software and or P/N of the unit which it gives you a populated list of numbers and my numbers are not in it. Called GM Dealer and they are saying it might not be in there due to its the latest P/N and gave me the P/N before it which is in the populated list. But the other problem was at the start of programming it kept popping up a Error Message. I also tried with the original module and I get the same Message. I use a Ford VCM2 on most all GM Vehicles the age. Being I had my Autel out already I decided to switch VCI out and give it a shot. I have never had issues with either one doing a GM. I got the same message.

At this point it had to be on the software side or com to the units. But with aftermarket scan tools I have seen some weird stuff. But before dragging a tech2 out I decided to hook up a drew tech plus3, and programming went right through. I really don't know what caused the other two units to not complete the flash, but would like to here what others have to say about it. Thinking maybe something to due with a identifier or something within the new module? BTW, I have performed a update at some point to this same vehicle cause it was under my vin list of active vin's. And im sure I had used the VCM2 back then. Thanks for any input

diag​.​net/file/f6d29sn9x… diag​.​net/file/f61b5vgzr…

Any suggestions will be appreciated. Thanks

+1
Al Technician
Hamilton, Ontario
Al Default
 

I recently had a similar issue with a GM BCM, I called the AC Delco tech support line …, Once he logged into my laptop through Team Viewer it worked. He said he has seen this happen before not sure why but it fixed the error issue and completed the programming

0 Default Ð Bounty Awarded
Brian Owner/Technician
Amanda, Ohio
Brian Default
 

What tool was you using? And they didn't change any settings, just logged in through TV?

0 Default Ð Bounty Awarded
Al Technician
Hamilton, Ontario
Al Default
 

They just logged in did not change any settings on my part. seems weird but it worked. I don,t know if he did something on there part he told me no. Using a Cardaq-M with Mega Can add-on

0 Default Ð Bounty Awarded
Israel Mobile Technician
Chicago, Illinois
Israel Default
 

If the part # Is not listed and you get error code you would need to call ACdelco tech support with that code, some times they have to make or fix file for that particular module. hope this helps good luck.

+2 Default Ð Bounty Awarded
Michael Owner/Technician
Irving, Texas
Michael Default
 

If the part number is wrong, it will fail. I played around with using different part numbers and locked some modules up, especially radios. Call them and they can let you know if it will work and give you a number to put in SPS.

0 Default Ð Bounty Awarded
Brian Owner/Technician
Amanda, Ohio
Brian Default
 

Thanks for the info. I did contact them but of course they was closed. I ended up using the dealer provided P/N and it worked. But plan on calling Monday and see what they have to say. Thanks again

0 Default Ð Bounty Awarded
Michael Owner/Technician
Irving, Texas
Michael Default
 

Ran into the same problem this afternoon with them being closed. Lost a vin I purchased in SPS list and didn’t want to spend another $40 lol.

0 Default Ð Bounty Awarded
Brian Owner/Technician
Amanda, Ohio
Brian Default
 

Are you sure it got added? And theres not a slot still available

0 Default Ð Bounty Awarded
Michael Owner/Technician
Irving, Texas
Michael Default
 

I used it for a week, but then the vin was gone this morning. I’ll call them Monday and find out what happen. No slots available.

0 Default Ð Bounty Awarded
Brian Owner/Technician
Amanda, Ohio
Brian Default
 

Lol, that's crazy. Iv never had that happen.

0 Default Ð Bounty Awarded
Michael Owner/Technician
Irving, Texas
Michael Default
 

Programming events was limit to 20 and then was deleted.

0 Default Ð Bounty Awarded
Brian Owner/Technician
Amanda, Ohio
Brian Default
 

You meen you have flashed it 20 times, or 20 vins and they delete then after that? I will have to look, but im sure i have over 20 vins, but could be wrong.

0 Default Ð Bounty Awarded
Michael Owner/Technician
Irving, Texas
Michael Default
 

Flashed the same vehicle 20 times. You are allowed one per module. I do flood damage vehicles, so 20 can add up fast, especially when we reflash swapping parts.

0 Default Ð Bounty Awarded
Walter Mobile Technician
Plantation, Florida
Walter Default
 

It has been said many times and as you see it's true. It's always best to use the OE device but if that's not possible use a Cardaq with the latest firmware and software. This has been my experience this is why I myself and others have all OE devices. It prevents you from wasting your time trying to resolve an issue that is not there and you know time is $$$. The time you save will pay for the…

0 Default Ð Bounty Awarded
Brian Owner/Technician
Amanda, Ohio
Brian Default
 

I'll agree with that 110%! Like this example, have done many using the VCM2 but it let me down one time! Until now, i haven't pulled out the Tech2 for anything newer than 05.

0 Default Ð Bounty Awarded
Walter Mobile Technician
Plantation, Florida
Walter Default
 

I would have used MDI2, not sure if the Tech2 would have completed the programming and I believe the CANdi module would be needed. .

0 Default Ð Bounty Awarded
Brian Owner/Technician
Amanda, Ohio
Brian Default
 

I have a Tech2 with a Candi. I believe it would have due to that was the preferred way layed out in SI.

0 Default Ð Bounty Awarded
Scott Owner
Moreno Valley, California
Scott Default
 

Hi Brian, I just wanted to comment on your web browser. I noticed you're using Edge, they have an update for that, but that is not the recommended browser. gsi​.​ext​.​gm​.​com/userguides/Aft…​.​pdf I realize IE11 and their Java are out of date, but that's what they want me to use. Programming can be difficult at times, but going 'off the…

0 Default Ð Bounty Awarded
Brian Owner/Technician
Amanda, Ohio
Brian Default
 

Thanks Scott for the heads up. I thought i switch to Edge for that reason.

0 Default Ð Bounty Awarded